Bug fix for SharePoint document links in VS vNext

Submitted another bug to Microsoft, this time regarding the fact that you cannot edit a SharePoint document opened from a work item in the VS IDE. After I submitted a screen capture of the bug yesterday Microsoft has confirmed that this is a bug in VS ALM 2010. The good news is that they will fix this in VS vNext where ā€œwe now launch the external browser rather than the internal VS browser when opening hyperlinksā€. Until vNext arrives we will have to use work arounds. Fortunately there are several of those. Because the source of the problem is the VS internal browser opening the document in any other way you can think of does not cause this bug to appear.

TFS Power Tool bug fix

Back in October I submitted a bug to Connect regarding the Process Editor and the fact that it makes background changes to the WIT xml files without notifying the user. Yesterday Microsoft posted a reply that this will be fixed in the next version of TFS Power Tools. When the next version will be released is not known, but February and Q1 2011 has been mentioned. I canā€™t wait, it is going to save me some serious headaches when editing work items!

Jesfer brought back to life

I finally found some time to get my blog up and running again. Even found a nice theme to use. Needs some tweeking but it is good enough for the moment.

I have no idea why my blog died on me (bored from inactivity maybe) but instead of debugging it I choose to just move on to BlogEnginge.Net 1.5. Exporting settings and posts was more or less a matter of copy/paste šŸ™‚